質問・問題
チャンネル接続時のエラー (Invalid Token) について、どのような原因が考えられますか
回答・解決方法
【例】
以下のようなケースで Invalid Token に関するエラーが返されます。
- NativeSDK 利用時: joinChannel でのチャンネル接続時、onError コールバック経由で ERR_INVALID_TOKEN(110) が報告される
- WebSDK 3.x 利用時: Client.join でのチャンネル接続時、コンソールに NO_AUTHORIZED(110) が表示される
- WebSDK 4.x 利用時: AgoraRTCClient.join でのチャンネル接続時、コンソールに次のメッセージが表示される
AgoraRTCError CAN_NOT_GET_GATEWAY_SERVER: invalid token, authorized failed
【原因】
以下の理由でトークン (token) が無効になっている可能性が考えられます。
- プロジェクトで App Certificate を有効にしているにも関わらず、チャンネル接続時にトークンを渡さなかった
- プロジェクトで App Certificate を有効にしていないにも関わらず、チャンネル接続時にトークンを渡した
- トークン生成時に使用した App ID、User ID、チャンネル名が、チャンネル接続時に使用した情報と合致していない
【解決方法】
- プロジェクト設定にて App Certificate の設定をご確認ください:
- 有効になっている場合、チャンネル接続時にトークンを渡す必要があります
- 有効になっていない場合、トークンを使わずにチャンネル接続してください
- トークン生成時に使用した App ID、User ID、チャンネル名、それぞれが以下の場面で同じ値が使われているか確認してください:
- App ID: Agora サービスの初期化に使うものと合致しているか
- Uesr ID およびチャンネル名: チャンネル接続時に使うものと合致しているか